Outdated software on Healthcare IT Devices Introduce Increased Security Risk

Duo Security, a secure access platform provider, recently found a significant number of devices in the healthcare industry pose a security risk due to running outdated versions of Adobe Flash. Flash is a software programming platform for delivering web-based content and applications.

In a study of over 250,000 devices including desktop computers, laptops and mobile devices, Duo Security found that half were running outdated versions of Flash. Outdated versions of Flash expose the device to potential threats and data loss through hacks and malware.

It is critical that organizations have a defined process and schedule for applying updates and patches on all IT systems. You can find the latest Flash update at  https://helpx.adobe.com/flash-player.html.

If you require additional help, we provide a range of security auditing and remediation services as well as long-term security planning . Please contact us at 303.757.0779 or HHowerton@Greystonetech.com.